Off-net broadband services down

Major incident Network Core Nationwide FTTx
2022-02-21 06:54 BST · 1 hour, 40 minutes

Updates

Resolved

The fibre provider believe the fault is now resolved, however we will be monitoring closely.

February 21, 2022 · 08:34 BST
Investigating

We’ve had confirmation now that this is a problem with the fibre provider at the Farnborough end and they have engineers working on the problem now.

February 21, 2022 · 07:42 BST
Issue

We have a core fibre problem between Farnborough and London which is impacting our nationwide (not Farnborough or Basingstoke) FTTx services. We are investigating this now.

February 21, 2022 · 07:35 BST

← Back