Wholesale FTTx Outage

Minor incident Network Core Nationwide FTTx
2021-10-13 11:54 GMT · 5 hours, 47 minutes

Updates

Resolved

All connections have been back for over an hour.

October 13, 2021 · 17:42 GMT
De-escalate

Zen suffered from a power issue in a datacentre which triggered a large scale outage of broadband lines. If your internet connection is still down please turn the power off and then back on on your router and the issue should be resolved.

October 13, 2021 · 14:08 GMT
Issue

Our broadband customers outside of the Basingstoke<>Farnborough area are currently effected by a large issue with our wholesale provider Zen. We’ll update this page when we know more.

October 13, 2021 · 11:56 GMT

← Back