Service Outage - Clare Park / Crondall / Wimble Hill

Minor incident Other
2026-05-30 09:07 BST · 9 hours, 15 minutes

Updates

Update

The UPS has failed overnight at the cabinet.

We are bypassing that and services will be up on utility power only. This means if there is a power cut, the services will drop again.

We will perform maintenance next week to 10 days to replace the UPS, which will be published once dates are confirmed.

May 30, 2026 · 09:48 BST
Issue

We are aware of total service outage at the above locations, engineer are investigating with our connectivity supplier and we will update at 10:30.

May 30, 2026 · 09:07 BST

← Back