Transit Issue

Major incident Network Core Nationwide Ethernet Nationwide FTTx Basingstoke Farnborough Control Panel
2020-12-14 09:49 GMT · 3 minutes

Updates

Resolved

Service is back up.

December 14, 2020 · 09:52 GMT
Issue

We are having an issue with one of our upstream network transit providers. We are working around the issue and investigating.

December 14, 2020 · 09:49 GMT

← Back