Issues with VoIP from Hampshire Broadband customers
Minor incident
Other
2025-11-11 10:33 GMT
· 4 hours, 4 minutes
Updates
Resolved
November 11, 2025 · 14:37 GMT
This has been resolved, apologies for any inconvenience caused.
Issue
November 11, 2025 · 10:33 GMT
We are aware of issues with Hampshire Broadband customers having telephony issues. This may manifest itself as no service.
Our engineers are working on it and have identified the issue. A resolution is being devised and will be implemented as soon as verified and safe to do so.
← Back
1310 Network