Global routing issues impacting your Internet experience

Major incident Other
2020-08-30 14:38 BST · 21 hours, 39 minutes

Updates

Resolved

This issue concluded yesterday and we’ve not seen any recurrence.

If you are interested in the technical understanding behind what happened there is a fantastic write up by Cloudflare available here https://blog.cloudflare.com/analysis-of-todays-centurylink-level-3-outage/

November 4, 2021 · 15:24 BST
Monitoring

There is currently a major problem with a tier 1 transit provider called Centurylink (also known as Level3). They have had ongoing issues all day, and this is manifeting in large chunks of the Internet simply not working.

Please check out https://downdetector.co.uk/ for a view of the scale of the problem.

Please be assured this is nothing to do with 1310, and unfortunately there is nothing we can do to work around the issue for you.

November 4, 2021 · 15:24 BST

← Back