Outage affecting some Lansbury Business Park Customers

Minor incident Other
2025-07-22 15:48 BST · 1 week, 4 hours, 43 minutes

Updates

Resolved

Issue has been resolved at the site

July 29, 2025 · 20:32 BST
Investigating

This was caused by local power engineers turning off the power to the local switch during remoddeling work in the area .

This has been remediated on site and connections have been restored.

July 22, 2025 · 16:01 BST
Issue

We have been made aware that some of the customers in Lansbury business park are offline. We are investigating the problem and will provide an update shortly

July 22, 2025 · 15:48 BST

← Back