Intermittent internet access for some customers

Minor incident Network Core Nationwide Ethernet Nationwide FTTx Basingstoke Farnborough Langley Rothwell
2025-06-27 22:47 BST · 4 days, 17 hours, 19 minutes

Updates

Resolved

This has been resolved

June 28, 2025 · 11:06 BST
Issue

We are aware of issues accessing the internet for some users. Our team are actively looking into this and will provide an update shortly.

Apologies for any inconvenience this is causing.

June 27, 2025 · 22:47 BST

← Back