Planned Maintenance – Monk Sherborne & Sherborne St John from 2025-06-09 21:00 BST to 2025-06-09 22:20 BST

Scheduled maintenance Network Core Basingstoke
2025-06-09 21:00 BST · 1 hour, 20 minutes

Updates

Resolved

All maintenance has been completed without issue.

June 9, 2025 · 22:20 BST
Update

This work has now been completed. All customers are back online.

If you’re having a problem with your internet connection, please call the team tomorrow from 9am where they will be happy to assist you on 0333 300 1310!

June 9, 2025 · 22:19 BST
Scheduled

🔧 What’s happening

We’re upgrading critical hardware at the Monk Sherborne exchange to increase service capacity beyond our current 900Mbps limit. This will involve installing new core equipment, during which customers in Monk Sherborne and Sherborne St John may experience a brief outage of up to 30 minutes.


🚀 What this means for you

Once complete, this upgrade will enable new packages offering speeds up to 3Gbps.
Customers who upgrade to the new packages and renew their contract will receive 3 months at their current package price as an introductory offer.


ℹ️ Additional Info

  • No action is required — services will resume automatically once maintenance is complete.
  • For any assistance, please get in touch with our fabulous support team via our support portal or 0333 300 1310.

Status: 🔧 Scheduled Maintenance
Impact Level: ⚠️ Moderate

June 3, 2025 · 15:00 BST

← Back