1310 Phone Line Unavailable

Minor incident Other
2025-03-14 10:43 GMT · 2 days, 27 minutes

Updates

Resolved

This was resolved with the first hour.

March 16, 2025 · 11:10 GMT
Issue

We are aware that our inbound phone system on 0333 300 1310 is currently offline and we are investigating the problem.

We do not currently have an ETA for restoration, however you can email help@1310.io or go to https://control.1310.io to login to your account to raise a support request.

March 14, 2025 · 10:43 GMT

← Back