Upton Power Failure

Minor incident POPs Upton
2024-09-03 19:59 BST · 1 day, 2 hours, 55 minutes

Updates

Resolved

This has been resolved and some preventative maintenance will be required in the future.

September 4, 2024 · 22:54 BST
De-escalate

Engineers have flipped the faulty breaker and power has been restored. Awaiting RCA for issue and long term resolution

September 3, 2024 · 20:40 BST
Issue

Mains power to Upton has failed again - Batteries have run through their 30 minute duration and the generator has not fired.

Site is hard down until the power is restored or generators are started.

We have personell on route to the location to identify the issue and report back. Next update due at 20:30

September 3, 2024 · 19:59 BST

← Back