Power outage at Upton POP

Minor incident POPs Upton
2024-09-01 08:52 BST · 1 day, 6 hours, 18 minutes

Updates

Resolved

This is resolved and the issue should not reoccur. Testing has been completed.

September 2, 2024 · 15:03 BST
De-escalate

Site is back on grid power. Incoming breaker needed a hard reset after the surge. Investigations will follow to ensure generator fires as expected for future events.

September 1, 2024 · 09:09 BST
Issue

The power into Upton POP site has failed. The batteries have run flat and the backup generator has not auto started.

We have people on site investigating the problem and will update with an ETA for resolution soon.

September 1, 2024 · 08:52 BST

← Back