Basingstoke Telephone exchange without power

Minor incident Network Core Basingstoke
2024-02-13 01:24 BST · 1 week, 4 days, 7 hours, 20 minutes

Updates

Resolved

The power has been stable here for 10+ days. The issue appears to have been a weak fuse in the supply from the building. We do not expect a repeat event.

February 24, 2024 · 08:44 BST
Investigating

Our engineers are on site and working with Openreach who have just arrived.

We have worked around the lack of power for now, awaiting a full fix. Customers should be back online.

February 13, 2024 · 07:20 BST
Investigating

At approximately 23:00 on Monday 12th February Basingstoke telephone exchange lost power. Our monitoring system picked this up and we were alerted. All our equipment runs on UPS. The UPS has lasted 2.5 hours and has now run out of battery.

Currently we have no power to equipment in THBZ and we are investigating with Openreach.

Our racks are dual fed and we have an extended duration battery pack within which would normally cover any short power outages.

February 13, 2024 · 01:24 BST

← Back