William Hill, Reddit, Netflix services unavailable to some 1310 customers

Minor incident Network Core Nationwide Ethernet Nationwide FTTx Basingstoke Farnborough Langley Rothwell
2024-01-06 10:54 BST · 1 week, 8 hours, 4 minutes

Updates

Resolved

This has been resolved.

January 9, 2024 · 18:59 BST
Resolved

This has been resolved.

January 9, 2024 · 18:59 BST
Issue

We have been made aware that some users are unable to access services from William Hill, Reddit and Netflix due to IP address blacklisting.

We are actively working with these providers to identify the issue and resolve.

January 6, 2024 · 10:54 BST

← Back