Power cut at Langley - Network

Minor incident Network Core Langley
2023-10-20 08:05 BST · 4 hours, 37 minutes

Updates

Resolved

This was caused by flooding in the area causing a power socket to become submerged tripping the RCD.

This has been resolved and power is back online. However with adverse weather this could happen again. We will look at solutions to prevent this.

October 20, 2023 · 11:42 BST
Issue

We have a power outage at the head end at Langley.

The equipment has had water leak on it. Engineers have been dispatched to investigate and remediate if possible.

October 20, 2023 · 08:05 BST

← Back