Customer connections down

Major incident Network Core Nationwide FTTx
2023-07-16 10:14 BST · 1 hour, 37 minutes

Updates

Resolved

The issue is now resolved. This outage was related to an upstream issue with Zen, our 3rd party national broadband provider. Services seem to have resumed working normally.

If you are still having issues, please get in touch with us.

July 16, 2023 · 10:50 BST
Investigating

We have multiple reports from around the country that customers have no connection this morning. We’re investigating now and will update here.

July 16, 2023 · 10:00 BST

← Back